Pontiac GTO Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
i recently purchased my dads 05 gto auto. it has been sitting in his garage for 2 years and after getting the mechanicals ironed out, I noticed the odometer is blank. no numbers at all, screen is no longer back lit etc. the other 2 screens and all the other gauges work fine. I pulled the cluster and sent it in to my buddies cluster repair shop. he is making it sound like I should start shopping for a different cluster. I problem is, this is a fairly low mileage car at 26k and all the clusters online are higher mileage units. any ideas?
 

·
Registered
Joined
·
352 Posts

·
Registered
Joined
·
2,608 Posts
That's kind of like 'image burn' or 'screen burn' on a cellphone.......
 

·
Registered
Joined
·
352 Posts
That's kind of like 'image burn' or 'screen burn' on a cellphone.......
Yeah it's always fun when new problems occur. Driving a gto is like spinning the wheel of broken car parts. You never know where it's gonna land lol.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
just a follow up, I sent my cluster to Bohnman Customs, he had it less than a day and shipped it back. Works perfect now. I have spent a lot of time speaking with multiple companies that repair clusters with no help at all. Jeff at Bohnman Customs saved the day (and me a lot of money and headaches)
Highly recommend!
 

·
Registered
Joined
·
352 Posts
just a follow up, I sent my cluster to Bohnman Customs, he had it less than a day and shipped it back. Works perfect now. I have spent a lot of time speaking with multiple companies that repair clusters with no help at all. Jeff at Bohnman Customs saved the day (and me a lot of money and headaches)
Highly recommend!
Very nice man! Glad that worked out for you. I need to stop being lazy and send mine in lol
 
1 - 9 of 9 Posts
Top