Pontiac GTO Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Sup all been awhile since I've been on here glad to be back. Sat I got a new to me 2005 GTO one hell of a deal about 4 hours away from where I live at, when I picked it up it ran great, drove the hell out of it for about 10 hours that day only issue that I knew about was a little lag in starting the car like the starter was trying to go out and that night the A/C light started flickering on and off by itself couldn't turn it off, dunno what was going on there but the next morning got in it was going to take a drive but it wouldn't crank was only getting a clicking noise when turning the key, checked battery it was good all lights everything worked fine just wouldn't turn over so thinking the starter was out but car was parked on a incline and I was pretty screwed on jacking it up, every day since Sunday I've been going out there trying to see if it would turn over an I be dammed if it cranked yesterday, I was happy as hell because I could at least put it on level ground jack it up and check the starter out, then I seen the check engine light was on and the traction control was off and push that button nothing was happening so I went straight to Auto Zone and they plugged it up and it showed Crankshaft Position Sensor, my ? is for u GTO gurus could this all becoming from a bad sensor, I'm not mechanically inclined and not sure if I should buy the sensor if there's more that comes with it like a relearn or something, what do u guys think?
 
1 - 1 of 1 Posts
Top