Pontiac GTO Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
It looks like my dealer was either lazy or just pissed off at the deal I ended up with on my new GTO.

Thanks to everyone who replied to my previous thread about my squeak in the front wheel wells. It turns out that the red spring spacers are still in place in my front suspension, and therefore have likely been causing this loud squeak. I tried to pull them out last night but without luck. I have put about 150 miles on the car with the spacers in place, and put about 30 miles on it with the tires at 50 PSI. I have a dealer appt tomorrow to have this thing checked out. I hope no damage was done!

Does anyone have a list of items the dealer should have performed/corrected/removed prior to delivery? I hope they didn't neglect anything important in the drivetrain, or elsewhere.

Thanks again.
:cheers
 

·
Registered
Joined
·
142 Posts
I have purchased over 30 new cars and never have had the correct air pressure in the tires. I have had lug nuts fallen off more than once. Don't assume the car is right. My son's new gto had incorrect tire pressure in all 5 tires.
 

·
Registered
Joined
·
98 Posts
vehicle intro TSB

I saw a list of the TSBs (Technical Service Bulletins,) from Pontaic to the dealerships on another forum. I won't mention the name of the other forum here, as I do not know if it is PC for me to do so. :confused I saw a "Vehicle Intro" TSB for the 04 GTO in the list. As I read through the contents, it was obvious to me that the dealership where I got my car doesn't routinely have the service dept. read all the TSBs as they come out. I found incorrect tire pressures like you did, also the floormats were left loose, because the hardware that goes through the holes in the floormats and screws into the holes in the carpeting was left in the trunk where it was put for shipping, etc.. Have you wondered about the holes in your floormats and carpeting too? Anyways, you are not alone. You would think that any good service person would be interested and maybe curious enough to check this stuff out, especially for a newly introduced model being shipped from a country overseas. :rolleyes: I know I would if that was my job. Good luck with the dealer, I hope all goes well.

Maximental
 

·
Registered
Joined
·
56 Posts
cuspid said:
I have purchased over 30 new cars and never have had the correct air pressure in the tires. I have had lug nuts fallen off more than once. Don't assume the car is right. My son's new gto had incorrect tire pressure in all 5 tires.

I've only bought 2 new vehicles (99 s10 extreme, and 02 Dakota 4x4) and in both cases tires were over inflated and lug nuts were on too tight. Never had one fall off, I think that's crap if you're paying $30K+ hell even if the car costs $4K a wheel shouldn't fall off.

On my S10, the rear diff was really low (fluid wise). When buying a new car/truck, I would recommend, or put it in writing, that they (for free) check the diff fluid, trans fluid, and tire pressure. (other fluids like oil, power-steering, are on their checklist) I also advise as soon as "you" get the car home, back the lugs off, and tighten to manufacturer specs. Overtiring a wheel could cause the rotor to warp, and after 12K, it's not a warranty issue anymore.

Good luck
 

·
Registered
Joined
·
16 Posts
codebluemd said:
It looks like my dealer was either lazy or just pissed off at the deal I ended up with on my new GTO.

Thanks to everyone who replied to my previous thread about my squeak in the front wheel wells. It turns out that the red spring spacers are still in place in my front suspension, and therefore have likely been causing this loud squeak. I tried to pull them out last night but without luck. I have put about 150 miles on the car with the spacers in place, and put about 30 miles on it with the tires at 50 PSI. I have a dealer appt tomorrow to have this thing checked out. I hope no damage was done!

Does anyone have a list of items the dealer should have performed/corrected/removed prior to delivery? I hope they didn't neglect anything important in the drivetrain, or elsewhere.

Thanks again.
:cheers
See also my post in the tech section - WTF STIFF Suspension

Well she went away on a tilt tray a few minutes ago. "If" there is no damage other than the dealers credibility she should be back in an hour or two.
I have a copy of the dealer pre-delivery list which has lots of boxes ticked , but I suspect the pre-delivery consisted of a wash.
Even has the box for cig lighter & ashtray ticked - it doesn't have these.
 

·
Registered
Joined
·
161 Posts
I would have him do a quick check on your headlight setting. My low beam setting was low as were others at this site. I thought my low beams were terrible until I had them adjusted correctly. I believe the setting of the low beams was a problem on early build date 04's.
 
1 - 7 of 7 Posts
Top