Pontiac GTO Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
304 Posts
Discussion Starter · #1 ·
Sorry if this has been talked about. I read here often and searched for it before posting...

I just noticed today that when I shut the car off, take the key out, leave the car, lock it with the remote...my odometer stays on. Hours later when I returned to the car, it was still on. I just got home from work, and still the same thing. So now the odometer will be on overnight (well actually 24/7 til it gets fixed).

Also, if I am in the car and I take the key out of the ignition and then put it back in to listen to the radio, my check engine light sometimes comes on and might stay on even if I take the key out (but will shut off when I leave the car and lock it with the remote). One time it remained lit even after locking the car...but I started it and shut it off and that worked.

Finally, sometimes when I put the car in park, the speedo hits 60-70mph and beeps like crazy but falls back to 0 pretty much as quickly as it happened. I know the '04's had this issue and there is fix for this at the dealer with the computer (if i remember correctly?)

Any input is appreciated. Thanks.
 

·
Registered
Joined
·
2,100 Posts
I'd talk everything over with your dealer. Definitely about the odo and the false speed indications. I sometimes get a check engine light -- but it always clears up on its own. Something about the way the ignition sequencing, I guess. Wouldn't worry about that too much.
 

·
Registered
Joined
·
4 Posts
I had a problem with the gauges...my car was overheating right when I started it up. I took it to the dealer and they said there were two options....one was to update the programming the other was to replace the instrument cluster. The update didn't work so they replaced the instrument cluster...and also took off 4,000 miles. It is a known issue with the GTO and it was no problem to get the cluster replaced.
 

·
Registered
Joined
·
62 Posts
As for the odometer, it does stay on constantly with the ignition off,that is by design. All GTO's operate in this manner. The rest of your complaints are known issues that a flash update or gauge cluster replacement is suppose to repair, based on VIN
 

·
Registered
Joined
·
304 Posts
Discussion Starter · #5 ·
PhantomTiger said:
As for the odometer, it does stay on constantly with the ignition off,that is by design. All GTO's operate in this manner. The rest of your complaints are known issues that a flash update or gauge cluster replacement is suppose to repair, based on VIN
Are you positive that the odometer stays on ALL the time even after leaving and arming the car? My odometer always shut off until now.
 

·
Registered
Joined
·
2,100 Posts
After taking another look -- the odo stays on all the time. Never had a false speedo indicator -- but the temp gauge went nuts for a couple of seconds one time. Check engine light comes on sometimes when putting the ignition to the on position -- but not far enough to crank the starter. Usually shuts off in a few minutes.

When the car was brand new, less than 500 miles, the electrical system got confused a couple of times. One time the interior light, which I programmed to shut off immediately, just stayed on. Then the alarm went off for some strange reason. Fortuantely, both things cleared up after a few seconds and didn't return.

Best thing to do is to get a small notebook, keep it in the glovebox, and note anything that pops up so you can have the dealer check things out on your next visit.

Also, be sure to read your owner's manual -- particularly when it comes to programming stuff like the speed warning indicator, etc. There are some pretty neat features in the GTO -- but they don't just jump right out at you.
 

·
Registered
Joined
·
60 Posts
b_a_betterperson said:
After taking another look -- the odo stays on all the time. Never had a false speedo indicator -- but the temp gauge went nuts for a couple of seconds one time.
:agree

I've had my goat since Sept 04 and had it happen twice so far. But only for 3-4 seconds max, then it calms right back down. No way to tell the dealer to fix something like that.
 

·
Registered
Joined
·
10 Posts
I had the same intermittent guage problems and my dealer said they'd order a replacement. The way it works, they said, was that their "electronics center" would program the correct mileage into the odo and sent it to them for installation. They called and asked me to drop my car off 11 days ago. No new odo has arrived. So, for almost 2 weeks, I've been driving around in a crappy rental car (they are paying for it). As far as the new cluster, "They are working on it."

My first American car in 25 years.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top