Pontiac GTO Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
Have a few questions about my car (2004 GTO)

Engine Oil:
I use Mobil1 Full Synthetic 5w30 with Mobil1 Filter and change ever 5-6k miles. Car has 26.6k miles on it. Oil changes from Light Honey color to a deeper "Tan" color during this time. Sound accurate? Should it be lighter? My dealer said the oil was darker then it should be.....otherwise car runs in primo.

6 Speed Manual Tranny:
Never changed fluid from time of purchase with 10.8k miles on odo. Due? How often? Recommendations on fluid, or roll with GM supplied?

Transaxle:
Never changed fluid from time of purchase with 10.8k miles on odo. Due?
How often? Recommendations on fluid, or roll with the GM supplied? (Seems I've seen a number of posts on a number of forums where people had issues with non OEM fluids here.)

Magnetic Drain Plugs for all? Where do you get them? Are they needed? Popular with owners here?

Thanks for the help.

(Edited)

Coolant/Thermostat:
Currently use Prestone (Orange) 50/50 premix with stock thermostat. Car has been flushed once. Recommend a 'chemical flush' for this time? I also have an SLP 160° Thermostat now. 50/50 premix is ok to use with this? Or is a different mixture needed?

Has anyone used the 160° thermo? Any issues?
 

·
Registered
Joined
·
72 Posts
Discussion Starter #3
Sorry, not wanting to get flamed here.....I looked thru the manual before and again just now, but I don't see anything about the interval for changing the tranny and rear end. Also, what fluids are best? As stated above, I have seen posts here and other forums where people have had issues going to aftermarket fluids and end up going back to the OEM dealer supplied ones. Why is that? Also....it appears on the thermostat that it depends on the vehicle whether you will have problems or not? I've got the 160 here now and live in Ohio, so summers (especially this one) are hot and VERY humid. My car has NEVER overheated or even gone anywhere else but where it always goes on the temp scale, but it just worries me on how HOT under the hood it gets.....its sweltering in there on days like today....

Is this just being worriesome?
 

·
Premium Member
Joined
·
4,162 Posts
My comments in red.

Have a few questions about my car (2004 GTO)

Engine Oil:
I use Mobil1 Full Synthetic 5w30 with Mobil1 Filter and change ever 5-6k miles. Car has 26.6k miles on it. Oil changes from Light Honey color to a deeper "Tan" color during this time. Sound accurate? Should it be lighter? My dealer said the oil was darker then it should be.....otherwise car runs in primo.
I use Mobil 1 and change it every 5k miles. I was told it maybe over kill but thats what I feel like doing.
6 Speed Manual Tranny:
Never changed fluid from time of purchase with 10.8k miles on odo. Due? How often? Recommendations on fluid, or roll with GM supplied?
I think fluid is personal preferance. I changed mine when I took it apart. I've used Mobil 1 with some weird results then went with Dextron VI and it works well. The Dextron VI has smoother shifts than the stock fluid. Your fluid should be still good with the low miles you have.
Transaxle:
Never changed fluid from time of purchase with 10.8k miles on odo. Due?
How often? Recommendations on fluid, or roll with the GM supplied? (Seems I've seen a number of posts on a number of forums where people had issues with non OEM fluids here.)
The diff is by far the most touchy/finiky thing I've ever run across. It's a hit and miss with Royal Purple fluid some have problems and some don't. Right now I'm using Torco w/their Limited Slip Additive and got rid of most of the clunking that the RP and stock stuff gave me. Again with your low mileage I wouldn't worry.
Magnetic Drain Plugs for all? Where do you get them? Are they needed? Popular with owners here?
I'm using a mag drain plug. I bought it from Pepboys.
Thanks for the help.

(Edited)

Coolant/Thermostat:
Currently use Prestone (Orange) 50/50 premix with stock thermostat. Car has been flushed once. Recommend a 'chemical flush' for this time? I also have an SLP 160° Thermostat now. 50/50 premix is ok to use with this? Or is a different mixture needed?

Has anyone used the 160° thermo? Any issues?

I have a 160 in mine but they work better with lowered fan temps. Mixture depends on your climate, 50/50 is good for most some use 60/40 mix.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #5
Excellent! Thanks for the info. 1 question....how to change the fan setting?
 

·
Premium Member
Joined
·
4,162 Posts
You can adjust the fan temps with a hand held programmer or have it tuned. A tuner can tune it or you can tune it using EFILive or HPTuners.
 

·
Registered
Joined
·
3,765 Posts
I'm using RP syncromesh for my M6. It is a bit thinker then the stock stuff so when the car is cold it shifts a little tougher... but once up to temps, it is amazingly smooth.

I also used RP 75w-140 in the rear diff. It already has the FM in it and I've had no issues.

Bother fluids were changed last summer and I put about 13k miles on my car since.

Oil changes I do every 3-5k miles. I'm just using regular dino oil and a Pureolator filter. No issues at all. The color of the fluid isn't the way to tell if it is bad or not. A car with 250k miles will almost instatly turn even Amsoil black but that doesn't mean the oil needs reaplced.

Coolent I have kept with Prestone Dex-Col and no issues. Don't buy the pepboys T-stat because they fail every 4 months.

Fan setting are something that you need to tune as well.

I don't have the meganetic drain plug but plan on getting them next time I'm due. Not sure if it really makes a difference or not, but it def won't hurt anyting.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #8
So....if I were to put the 160 in with no tune the car would run correctly yes? Not adjusting the fan setting would mean that the fan would still kick on at the factory setting? Or?
 

·
Premium Member
Joined
·
4,162 Posts
So....if I were to put the 160 in with no tune the car would run correctly yes? Not adjusting the fan setting would mean that the fan would still kick on at the factory setting? Or?
The fans will kick on at factory settings. The 160 will cool the car off cooler while driving, but having the fans kick on earler will cool the car down while sitting still.
 
1 - 9 of 9 Posts
Top