Pontiac GTO Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all, here’s the problem I’m facing;
Every speed bump I roll over I hear a “loud” squeaking as my 67 conv goes up and down over the bump. Yesterday I replaced to old front shocks who’s bushing we’re shot and hoped that would improve the situation but no. I’ve also sprayed every rubber and metal joint with at-205 to recondition the old rubber, The next day are used some penetrating oil, this seem to reduce it by 30%. All tie rods, ball joints etc were replaced with new moog parts a year ago.

And I’ve searched all threads on squeaking noises from suspension. It’s infuriating to be driving such a great car and yet ...Squeak squeak over every bump
I realize it’s 52 years old and not a Toyota but there’s gotta be a way to get rid of the maddening embarrassing SQUEAKING &@!
Thanks in advance
Rob
 

·
Registered
Joined
·
4,207 Posts
Hi all, here’s the problem I’m facing;
Every speed bump I roll over I hear a “loud” squeaking as my 67 conv goes up and down over the bump. Yesterday I replaced to old front shocks who’s bushing we’re shot and hoped that would improve the situation but no. I’ve also sprayed every rubber and metal joint with at-205 to recondition the old rubber, The next day are used some penetrating oil, this seem to reduce it by 30%. All tie rods, ball joints etc were replaced with new moog parts a year ago.

And I’ve searched all threads on squeaking noises from suspension. It’s infuriating to be driving such a great car and yet ...Squeak squeak over every bump
I realize it’s 52 years old and not a Toyota but there’s gotta be a way to get rid of the maddening embarrassing SQUEAKING &@!
Thanks in advance
Rob
Control arm bushings.
 
1 - 2 of 2 Posts
Top