Pontiac GTO Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've seen a lot of posts regarding the P0496 diagnostic code (EVAP system issue), most of them relating to the gas cap not being fully tightened. That's what I assumed my problem was also for a while, so I ignored my CEL, until I started having trouble filling my fuel tank.

It takes fuel very slow. The gas pump keeps shutting off as if the tank is full, yet it's almost empty. I can only put about 0.3 gallons at a time, having to wait about ten seconds after each time the pump shuts off. It takes me 15 minutes to fill my tank!

Has anyone else had this problem, or heard of someone who has?

If so, is this something that I can fix, or do I have to go to a dealership?
 

·
Registered
Joined
·
91 Posts
This happens to me too but only a certain stations. I also used to get a P04** code but that ceased after I discontinued washing my engine additive out of the fill neck with the gas nozzle. I think the auto shut off is in correlation with the length of the fuel nozzle and the fact the our gas tank is in the trunk. The fill tube makes an almost 90* turn. Other than this I don't know what to say other than try a different station.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I initially thought it was the station as well. I went in and asked if anyone else had complained of too high of pressure in the pump. No one else had.

I tried many different stations, but I have the same problem at each one.
 

·
Registered
Joined
·
2 Posts
Slow fill

I have the same problem that I decided to jump in and find out why. I thought the vent was plugged and took it off and blew air into the tank. It went in fine. Then I got a mirror out and looked at the line that the hose connects to. The hole in the pipe is only about an 1/8" in size. I am going to drill it out to the pipe size. That isn't enough to let the vapors out of the tank when filling.
 

·
Former Moderator
Joined
·
4,081 Posts
It's an issue due to the quickie engineering to move the tank from under the car to where it is to meet federal regulations. I pull the nozzle out a little ways and don't fill it full blast.
 

·
Super Moderator
Joined
·
8,433 Posts
2 weeks ago went to fill mine. Pump kept shutting off before I knew it was filled. It gave the illusion it was filled. This happened at a BJ gas pump. Turned ignition on and it read still not filled. Drove down the road to Sunoco and it topped off at 3.5 or so more gallons filling it.

Bought the car new this is the first time it ever happened. Will occasionally click off with a gallon or so to spare and upon 'toying' with it am able to fill it.
 
1 - 6 of 6 Posts
Top