Pontiac GTO Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
The generator light is coming on while I am driving. The voltage and battery has been running over 16 volts, I then replaced the voltage regulator. But I am still having the same problem with the light staying on.

Does anyone have any ideas or suggestions?

Greatly appreciated Thanks!

-Dave
 

·
Premium Member
Joined
·
4,705 Posts
Could be a bad connection at the ignition switch, a bad connection at the alternator, or.....another bad regulator. the wire from the "A" terminal on the ignition switch is a resistance wire. WHAT YEAR CAR DO YOU HAVE???
 

·
Premium Member
Joined
·
4,705 Posts
:agree Ah yes, the infamous grounding issue! make sure ALL the proper parts have a good ground. Also check the VR plug and the harness bulkhead connector for a good connection........Hey Randy!......First thing to do is make sure your ALT is putting out !
 

·
Premium Member
Joined
·
4,705 Posts
Yep! Similar thing happened to a friend of mine. And most recently my engine guy put 3 starters in a Firebird before he got a good one!!!!!!!! Things ain't what they used to be!:willy: E
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
Thanks for all the help guys! I found a bad connector at the voltage regulator plug. I finally got a good VR on my 3rd try. Autozone I have had that problem with Autozone before when I bought a headlight switch and it was broken as well.
I got the right voltage reading now however the indicator light is still on. after looking at the wiring diagram I believe that traces back to the ignition switch.

I would like to replace that switch but I can't find one online, and Ames Performance and OPGI don't sell one either.
Does anyone know a place where i can buy an ignition switch?
Thanks
 

·
Registered
Joined
·
475 Posts
Thanks for all the help guys! I found a bad connector at the voltage regulator plug. I finally got a good VR on my 3rd try. Autozone I have had that problem with Autozone before when I bought a headlight switch and it was broken as well.
I got the right voltage reading now however the indicator light is still on. after looking at the wiring diagram I believe that traces back to the ignition switch.

I would like to replace that switch but I can't find one online, and Ames Performance and OPGI don't sell one either.
Does anyone know a place where i can buy an ignition switch?
Thanks
i doubt its the ignition switch.
 
1 - 10 of 10 Posts
Top