Pontiac GTO Forum banner

1 - 5 of 5 Posts

·
RIP (12/27/60-7/18/15)
Joined
·
767 Posts
Discussion Starter #1
Hi troops....
I moved the Goat out in the driveway and ran it for 15 mins. It's just sat in the garage for over 2 months now. There was maybe 2 tablespoons of coolant(water?) on the pan. The PS pump started howling and I discovered the line on the rear of the pump of kinda swollen, and the metal jacketing is "oozing" a tad when flexed.......I put in trans fluid, way to darn much and the res overflowed..........(they dont call me mr patients for nothing)
grrrrrrrrrrrrr..........gonna have to replace that hose.
1day less than 2 weeks it goes in for tires and a good front end alignment........then we can call for the state inspection.
It'll be 2 years this august...........cant wait to put some miles in it!!!!
hope all are well
Tips a hat to Geeter, Uncle E, and Bear........:cheers
:party::party::party::party::party::party::party::party:
 

·
64-67 Expert
Joined
·
8,569 Posts
Great news, Top. Thanks for posting. Those hoses are available at NAPA or the vendors, and are an easy bolt-on fix. Use a line wrench or crows-foot so as not to bugger up the fittings, tho'. Did you check out Eric's ride lately?? Oh man.....
 

·
RIP (12/27/60-7/18/15)
Joined
·
767 Posts
Discussion Starter #3
Yes I did!!!
Gall dang....now there's a car...WOW!!!
good thing he's kin folk!
:party::party:
 

·
Premium Member
Joined
·
4,703 Posts
TK !, you need to learn to pour more gently...it's an art, especially when it comes to liquor and transmission fluid. BRAKE FLUID WILL REMOVE PAINT!! thanks for the kind words gents!! UE :cheers:party:
 
1 - 5 of 5 Posts
Top