Pontiac GTO Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
hey guys im new on here and i could use some help. i bought my gto stock and since ive added a cold air intake, long tubes, straight pipes and spintech mufflers. i also upgraded the plugs and wires and its ran awesome since then. its been about 2 months now, and here in the past week it seems like i have a misfire, but ive had it checked and all the scans say it is ok. i do not have rear o2's plugged in, because i had them turned off in thought of having the straight pipes. the engine shakes occasionally and the gas monitor guage reads between 1-3 gallons per hour while it idles. does not do it all the time tho. i have no idea what it is, but it seems like the fuel is running too rich and i am getting engine codes for the o2's but not sure if that is the source of everything. i've heard tuning it could make it go away. it has never been tuned before and i dont want to waste my money on a tune if it is not going to help me with this problem. can someone please give me some input on this??? :confused:confused:confused
A second problem I'm having is when I go through a car wash, the car starts to shake and my rpm's fluctuate between 800-1500 randomly without me touching the gas while it idles in neutral. I think something may be getting wet when it sprays the under carriage. Other than that, I've never had any problems. Can someone help me figure this out? :willy:
 

·
Registered
Joined
·
444 Posts
re

When doing long tubes, You definately need a tune. You can get a hand held or dyno tune. Dyno tune is the best and will net you the most horsepower and overall drivability if the tuner knows what he is doing. A hand held tuner will tune out the o2's and depending on which tuner Diablo, slp diablo etc you can load a tune depending on which mods you have. I have an SLP diablo tuner and just loaded the basic tune as I do not have long tubes. ---Danfigg
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
thanks for the reply :D im hoping this is my problem and the dyno tune i am getting next week will fix everything. any idea on what could be getting wet when i go through a car wash and causing my rpm's to go crazy?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
solved

so it ended up just being bad 02's and the factory tune just wasnt cooperating with the parts i've put on. putting in new front o2's and turning off the rear o2's took away my check enginie light. throwing it on the dyno fixed my fuel mileage and made it stop running so rich. also gave me about 30 more hp at the rear, so if anyone else has this problem, this may fix it. also the new o2's made my car not hate water again. it doesnt freak out when i wash it anymore
:party:
 
1 - 4 of 4 Posts
Top