Pontiac GTO Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
70 GTO...putting the pieces back together after a botched restoration effort by a so called expert. Anyway, I reinstalled the dash and plugged it all together. When I pulled the light switch the passenger side low beam works. The drivers side the low beam is very dim and there seams to be a voltage bleed to the high beam as there is a faint glow from that headlight too. I hit the dimmer switch and no high beams at all. All other lights are functional. Directionals, parking, and rear lights work fine.
Before I pull the nose off and start replacing harnesses, does anyone have any ideas on where to start a trouble shooting effort?
Any help for this neophyte would be appreciated.
 

·
Registered
Joined
·
444 Posts
70 GTO...putting the pieces back together after a botched restoration effort by a so called expert. Anyway, I reinstalled the dash and plugged it all together. When I pulled the light switch the passenger side low beam works. The drivers side the low beam is very dim and there seams to be a voltage bleed to the high beam as there is a faint glow from that headlight too. I hit the dimmer switch and no high beams at all. All other lights are functional. Directionals, parking, and rear lights work fine.
Before I pull the nose off and start replacing harnesses, does anyone have any ideas on where to start a trouble shooting effort?
Any help for this neophyte would be appreciated.
Check and see if you have loose grounds behind the headlight/grill somewhere.
 

·
Registered
Joined
·
962 Posts
dimmer switches are known to fail also
and make your headlight act funny
usually they default to no brites in my cases of failure

good clean grounds

unplug the other light,,,?

swap bulbs ?

Scott
 

·
Registered
Joined
·
383 Posts
After the grounds i would pull the light switch and test voltage for the outputs...

Lighting systems on these old cars are pretty easy. Start with the switch and work your way back. The head light power has to go thru the high beam switch as well so test the voltage there next...
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Thanks...just installed the dash...i should be able to get to the light switch without pulling the entire dash out again. I’ll try that as well. Appreciate your response.
 

·
Registered
Joined
·
444 Posts
I believe there is a the ground backet behind the light switch and wiper bracket. If you want to try a new lightswitch, I bought one at a napa store but I had to ask for one for a 70 chevelle because nothing came up for Gto.
 

·
Registered
Joined
·
362 Posts
Sounds like the headlight itself is mis-wired. Either the high or low beam wires are on the ground wire terminal and are now back feeding through the high beam bulb looking for a ground. Found this photo on another site. Check to make sure the low beam bulbs are wired correctly.
 

Attachments

1 - 9 of 9 Posts
Top