Pontiac GTO Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
ok, here we go again... seems like i only post up issues with my care than anything... kinda getting on my nerves... but here it goes...

started saturday afternoon, my car is making a rattling noise... kinda like when you leave a tool on your motor and it vibrates when you turn on the car... that's what it sounds like... between that and maybe bearings going bad... i've got the mp112 maggie on and i haven't had any issues or noises like this before... just wondering what it could be and how to fix it ASAP!!! getting me discouraged not knowing... sprayed some wd40 on the idler pulley and shaft where the bearings are, and it still makes the noise... NOW, since this morning, its becoming intermittant... on the way in to work it didn't make a noise for about half the time coming in... then it started rattling back up again...

the car drives fine and doesn't bog down or act funny in any way... please, someone shed some light on this... its my main car so i need to get it fixed quick... thanks guys for hearing my bs again... lol
 

·
Registered
Joined
·
16 Posts
Discussion Starter #2
well i found out what it was... it was the supercharger... turns out i'm not the only one that's had this issue... found a couple threads on other forums with this problem... the pulley on the backside for the rotors crapped out... so all in all i had to remove it and ship it off to magnasun for repair... hopefully i'm not down a car too long...
 
1 - 2 of 2 Posts
Top