Pontiac GTO Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I have a 06 GTO I've only had a few months, the car has about 76,000 miles on it. I notice when I start the car and its running there is kind of a squeak/whistling noise. I cant tell if its a belt or pulley, or could it be the water pump? I have no loss of coolant and the only seepage I see is from the radiator cap, which I will replace. Should I go ahead and replace the water pump? and is that something my local NAPA store can order for me? Thanks
 

·
Registered
Joined
·
144 Posts
Its probably belt, tensioner or idler. Don't think its pump. If you have to replace the pump the local stores have the pump and stat in stock and its easy to change. Btw both mine and my budys water pumps started leaking at similar milleage.
 

·
Registered
Joined
·
49 Posts
My money is on belt or belt tensioner as well. The stock tensioner has a tendency to make a weird grinding or whistling noise.

Start the car and gently spray a little PB-50 Blaster All Purpose Lubricant on the belt tensioner where it spins on the spindle. DO NOT SPRAY THE BELT. Should quiet right up. If that is the original belt, definately replace as well.
 

·
Registered
Joined
·
49 Posts
Don't thank us yet. Only helps if that was indeed what was making the noise, lol. Doubt its the water pump. Water pumps have 2 modes.....they either work, or they don't. If they don't, 99.9% of the time they are dripping or leaking. You said yours isn't leaking, so just deducted it down to belt noise.
 

·
Registered
Joined
·
68 Posts
Just from reading your subject title, I was going to suggest your windshield wipers. Some windshield wipers have holes in the mounting brackets, and while driving they tend to make a whistling sound...

So, with that NOT being the issue...

Take a few minutes out of your day if possible, and stop by a friendly neighborhood mechanic, pop the hood, and see what you guys can come up with.
My next suggestion, would also be the belt tensioner.

Keep us updated on your problem, and if you're able to solve it.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #8
This sound is only on start up a high pitched squeak, I'm going to replace belt/tensioner
 
1 - 8 of 8 Posts
Top