Pontiac GTO Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter #1
I Have a 05 A4 and 2 different things that are different today than the 2 months I have owned this goat. Today here in california is pretty hot around 90 degress and I changed my spark plugs out with some new oem ac delcos.

Now usually temp gauge is at the same spot from prevouis days and today until what happen next.....

I pulled into wendys drive thru about 30 minuts ago and all of sudden for my first hearing it from this car i hear the electric fan run full blast sounded like it, I then was staring at the menu and then i hear a beutiful chime noise to my ears it was the hot temp alerting me and then I looked at the temp gauge and it was almost fully pegged.

So I was nervous and kept turning off the goat until I finally pulled out after paying and at this time the temp fianlly was to normal range, then brifly for about 20 seconds it went up some more but not high liem it did at the beggining of the drive thru. then it went back normal from there on so I hit the freeway back home.

ANyone know what is going on or something, thanks.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #2
Well dont know if the prevoius owner ever checked cooloant level at the radiator, but I remove the radiator cap tonight and theres no coolant in there its like half way down and I notice what I did see down in there with a flash light it looked kinda of brownish. Could it be so old that its time to change it out anyways with 50,000 miles on it 5 years old?

So I was thinking before changing out the thermostat, is refill with coolant and maybe buy a new radiator cap? Thanks
 

·
Registered
Joined
·
2 Posts
HAD EXACT SAME THING HAPPEN TO ME ON MY WAY TO WENDYS TOO!!! holy cow! but i have and 04. I was on a busy street all i did was turn on my emergancy lights and tried to glide the car in nutral for a bit until i reached a gas station. Bought some coolant and put it in. I only had 17k miles on it at the time now at 26k but yeah man i wouldnt worry about it as long as you put the fresh coolant in it
 

·
Registered
Joined
·
215 Posts
yeah man it was 110* out here where i live, never had a problem like that but it happens, ive heard of a few people having the same scare.....just flush the radiator and get some new coolant
 

·
Registered
Joined
·
198 Posts
Discussion Starter #5
HAD EXACT SAME THING HAPPEN TO ME ON MY WAY TO WENDYS TOO!!! holy cow! but i have and 04. I was on a busy street all i did was turn on my emergancy lights and tried to glide the car in nutral for a bit until i reached a gas station. Bought some coolant and put it in. I only had 17k miles on it at the time now at 26k but yeah man i wouldnt worry about it as long as you put the fresh coolant in it
Yea tommorow im going to put in fresh dexcool 50/50 and new raidator cap and monitor it make sure it stays fine.
 
1 - 5 of 5 Posts
Top