Pontiac GTO Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Gotta love the play on words.
My brother has an 05 GTO LS2 and we had a bit of a Nitrous explosion one day. Needless to say I pulled the heads, checked the pistons, did a valve job and replaced the destroyed intake with a new shiny aluminum one. Can runs and drives like a champ but I have a loud knock in the mornings on a cold start that was never there before. After it warms up it goes away. I have several LS motors over the years (LS1, 3x LS2, and an LS7) and I know they can be loud but this is a bit much. I run 5w30 penzoil which is what I have always ran in this car with no noise until now. Any ideas?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
BTW I wish I had a more positive post for my first post, but I was told this would be the place to ask the people with experience.
 

·
Premium Member
Joined
·
838 Posts
Could have something to the explosion, but I don't know what it could be. Ls motors
with their short piston skirts have piston slap on start up. Wear causes clearance and
more slap. Nitrous, with it high cylinder pressure causes much more wear than normal
and collapse the skirts.
When the pistons heat up and expand, they quieten down.
Most of the good knowledgeable people on the forum don't live here, but
will chime when they get a chance.

Larry
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks for the info. I only ran 1 and a half bottles through the car with 150 shot and it went from zero noise to pretty loud after the one incident. Car only has about 30,000 miles on it.
 

·
Registered
Joined
·
259 Posts
i had some dmg to my cam when i pulled my motor, it was one of those MTI cams made by Comp Cams that didn't harden right... anyways, the hardened part started chipping away from where the roller lifter rolls on it... about 6 lifters did this while it was in service. it made a lot of noise on the top end. honestly it really sounded like super loud injector clicking and grinding.

that is about the extent of my knocking problems.

oh i also had a bad oil press sensor that lead to a spun bearing... that was more like a banging noise :(
 

·
Registered
Joined
·
3,765 Posts
WOuldn't a bad oil pressure sensor throw a CEL?
 
1 - 9 of 9 Posts
Top