Pontiac GTO Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello this is my first post and I'm still learning about stuff and trying to gain some knowledge so please don't be rude and bare with me....

So at the moment my 06 gto seems to be slower than normal and I was wondering if it could be due to my check engine light let me start by saying I bought the car and for the first month was loving it until... I thought I some how blew the motor because there was a EXTREMELY LOUD KNOCKING SOUND but it turns out my catalytic converter .
Now I understand it would have been better to replace the cats but at the time it just wasn't possible due to financial reasons and I still needed my car to get to work so I took the only route I could and gutted it and once I did it the knock was gone but the cel was now on and the car feels slower than it did and on top of that my clutch went out so I replaced it with a stock clutch and after I found out that the previous clutch was a performance clutch so now I am trying to figure out what the loss of power is from so any input would be appreciated thanks
 

·
Premium Member
Joined
·
839 Posts
Have you scanned it? A gutted/removed cat will set a CEL, but since you had severe knocking, you may have other
problems, also.
Disconnect the battery for a few minutes to reset things.

Larry
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Have you scanned it? A gutted/removed cat will set a CEL, but since you had severe knocking, you may have other
problems, also.
Disconnect the battery for a few minutes to reset things.

Larry
yeah i scanned and its coming up with the cat code and everything sounds normal no more knockng since ive gutted the cats but im loosing power since then my average 0-60 was 4.4 and now its 5.5 its just odd someone tried telling me it could be because i had a racing clutch previously and now i have a stock one but i am wondering if the sensors for that cat could be th cuase?
 

·
Premium Member
Joined
·
839 Posts
yeah i scanned and its coming up with the cat code and everything sounds normal no more knockng since ive gutted the cats but im loosing power since then my average 0-60 was 4.4 and now its 5.5 its just odd someone tried telling me it could be because i had a racing clutch previously and now i have a stock one but i am wondering if the sensors for that cat could be th cuase?
The rear O2 sensors only check for a working cat, they have nothing to do with the tune or performance.
Gutting or removing the cats may require a custom tune to get the A/F correct. When installing headers without
cats, you require a custom tune. You need to talk to a good tuner.
For best performance, get LT Headers without cats and get a custom tune.

Larry
 
1 - 4 of 4 Posts
Top