Pontiac GTO Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
i just bought a 2005 gto tday and i am a proud owner of it. date 2-18-2011 at 11:45 a.m.

a few problems im having with it.

will not pass emissions yet because battery died and needs to be run so many miles to reset? is this true?

drove it home from work tonight and headlights and foglamps work except bottom left fog. bulb ordered. but when i tried every setting available the back taillights would not light up in nighttime mode only when i braked but all taillights work then. how do i fix this? has aftermarket headllights with halos that work okay seem a little dim. possibly the problem with taillights?

also the gauges will not light up. was a dangerous ride home, only could use electronic speedmeter. please let me know how to fix this? maybe fuse or relay for this and the taillights?

also how do i run codes. turn key 3 times or hold the mode and set key. will it read the codes being thrown off? some modes i could not get too. i wanted the car to beep when locked or unlocked.

i will check fuses tomorrow after i get off work at 3 but i wanted to check and make sure nothing else was wrong with it before getting inspected monday.

also i cant get anything on the blapunkt cd player to work. only steering wheel controls work? how do i fix this?

also does the green electronic read outs able to change color or only when bought cause i like the red color electronic look.
 

·
Registered
Joined
·
112 Posts
Hi

I could try answering some of your question. Wether you will pass emisson or not is all about the condition of your cats and the tune. If you got the stock tune in your car it´s only a matter of the condition of the cats. A bad battery may throw Some fault codes lika ABS problem but have nothing to do with emissions.

Begin checking the fuses for your problems, you got a fuse box in the engine compartment and one in the height of the drivers seat beneath the steering wheel.

To check fault codes you need a handheld computer (obdc). Although engine oil change indicator you could reset by pressing the pedal like 4 times or so.

Yes you could do one thing about the blaupunkt cd, Change it !!!!! It´s crap.. Put a double din touchscreen in there and your sound will be 100 times better.

Do you mean the instrumen cluster or like AC and other buttons? The buttons is green and cannot be changed without buying other. The instrument cluster cannot change color either except turning the night mode on. (but you could buy other colors on this aswell) If you wanna change the looks of your instrument cluster then former gtogrilles is good

Instrument Cluster Lighting Modifications - $125.00 : West Coast Speed, Custom Automotive Accessories
 

·
Registered
Joined
·
1,116 Posts
Your problem with the lights could be related to the aftermarket headlight/foglight setup. If they are HID they may be drawing too much power. Try stock light bulbs to see if problem goes away. Almost sounds like someone did not know what they were doing. I have also heard that HID's will fade or turn a light pink when about to go out.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
checked out the car today. park lamp fuse was blown and i replaced it. everything seems to be in working order. taillights are dim when driving at night like suppose to be. the aftermarket headlights (headlights are european lights no hids just halogen. really great at night though) are working and the instrument cluster is lit up now due to fuse change. only problem i have no and have no idea how to fix is the cd player. it is locked up or something, all i can use is the buttons on the steering wheel. will not eject or load cd but it did eject a cd that was unreadable. has cds in the player now and some play with no problem. if anyone knows how to unlock the cd player that would help me out alot. ill take it to get emissions tested tuesday and get back to you on that. so i just got emissions and the cd player wont work. paid 14k for a 2005 gto with 62k miles so i think i got a good deal. let me know what you think. also thanks for your time at looking and helping me out. normally i search to find answers but i needed responses and i was anxious. i mean come on i just got a GTO.
 

·
Registered
Joined
·
12 Posts
Good thing it was just a fuse! As for the radio I'm with the other cat on here.......CHANGE IT!!! the factory radio might sound alright as of now but, if you throw a new unit in there it's gonna blow it out the box!!! JVC sells an awesome double din that's really nice for 175 on Crutchfield.com comes with everything to do it with. Check it out, good luck bro!
 
1 - 5 of 5 Posts
Top