Pontiac GTO Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I have a some weird noise coming from underneath my GTO when I engage the clutch. Its a "tick-tick-tick-tick" then stops when I release the clutch. It also is making a whining noise when I shift. There is no pulsing sensation on the pedal, and its not slipping. Car drives fine, but I have a bad feeling something serious is up.
Anyone heard of this noise before, or am I being paranoid?

Please help!


------
04 5.7 GTO
 

·
Registered
Joined
·
21 Posts
Discussion Starter #2
Turns out it was the throw bearing, out with the old...in with the new.
Spec stage 2+ and install $1000

thanks for no help fellas' :willy:
 

·
Premium Member
Joined
·
4,162 Posts
Not many people turn their own wrenches, some have jobs and some don't have the ability to troulbleshoot thru post.

You should have invested in a remote bleeder while the tranny being pulled.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
Yeah I know and understand that...I was honestly just joking when I said thanks for no help. It's all good, luckily I got it all figured out. :D
 

·
Registered
Joined
·
2,619 Posts
I wrench and shees, I spend a lot of time but not 24/7 on here. I would have told you to skip the Spec tho. . . :D
Me too, on both counts. These cars cost enough to maintain without paying someone else to do the work....
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
why skip the spec clutch? I did some research and they seem to be pretty reliable for the most part. Of course some have issues and some don't. Lots of people were telling me to go LS7, but....I decided not too. What sucks is I'm outa my goat for a week. In the mean time I bought a B&M ripper shifter to put one once I get'er back.
 
1 - 7 of 7 Posts
Top