Pontiac GTO Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
A bev of models housing the 5.3-, 5.7-, 6.0-and 7.0 liter engines may leak from the rear of the engine.GM officials say the oil is coming from the rear cover assembly and is because of porosity of the engine block.
The models involved are; 2004-2006 Buick Rainier,Chevrolet SSR, and PONTIAC GTO; 2003-2006 Chevrolet Corvette and Trailblazer,Gmc Envoy,XUV and Sierra;2005-2006 Chevrolet TrailBlazer SS,Silverado and Silverado SS,Pontiac Grand Prix GXP,Saab 97-X; and 2006 Impals SS and Monte Carlo SS. Anew rear cover assembly gasket and special sealant should keep all the liquids inside.No word on wheather repairs will be covered outside the warrenty.
 

·
Registered
Joined
·
202 Posts
Dizamn it.
 

·
Registered
Joined
·
3,445 Posts
I think my GTO had this problem. Looking on the floor probably won't help. All I had was a slight amount of oil on the block towards the back. Every once and a while I noticed a drop on the ground, but wasn't sure if it was from my car or not. Best bet is to visually inspect underneath the car when it's lifted.
 

·
Registered
Joined
·
178 Posts
At 5500 miles, I was 4 1/2 quarts low on oil. I had it on the rack the other day and the oil pan was pretty oily. I sprayed it down with brake cleaner and I am checking it this week to see how bad it is.:mad: :shutme
 

·
Registered
Joined
·
4 Posts
i have had that problem repaired today all so the rearend has been replaced for the first time the new one suck allso whineing it is geting old been to the dealer five times i have 8500 miles
 

·
Registered
Joined
·
304 Posts
Is this an "official" recall yet? GM would sent a letter if it was, right?

I've noticed a very small mark that's being left in the driveway, but haven't figured out which car it is yet. The leak is from the back of the motor? The mark in my driveway looks like whatever is leaking from someones car would be coming from upfront.
 

·
Registered
Joined
·
364 Posts
I spend way too much time on the Corvette forums... and this is the first I've ever heard of this issue. Can't be that common.
 
1 - 9 of 9 Posts
Top