Pontiac GTO Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Hello everyone,

I have a LS1 GTO cat delete that is having some serious misfire issues. The check engine light flashes at 2000 to 4000 rpm, the light stays on at idle (rough idle) and no misfires over 4000 revolution. I check the wiring and nothing seems to be out of order and tried to detect which cylinder is misfiring but it's every one of the cylinder misfiring at random!

background: 04 LS1 GTO 62k miles. The car has headers, straight pipes, cat delete with diablosport O2off Tune. 3" Full exhaust with 2 32" resonators and mufflers.

I have recently started putting premium Costco gas in the car. My friend who gets gas from the same spot is having fuel related issues. He drives an integra GSR . Not sure if this is a coincidence or it is bad costco gas causing this.

I stopped by Autozone and put a whole thing of fuel injector cleaner and octane boost with hydration eliminator in the car and drove it home for 10 miles. It didn't drive any better!

The car sounds and drives like a tractor and I dont wanna damage anything so you help is definitely appreciated.
 

·
Registered
Joined
·
2,632 Posts
A good reason not to use fuel additives. You'll probably need to burn those additives out of your fuel system and then run a tank or two of gas from the 'different station' before you could rule out the gas itself being the problem.
 

·
Registered
Joined
·
91 Posts
Make sure there is no clog in airflow either, recently seen issues of MAF or just clogs causing not enough air and misfirings happen bad at idle but as the vehicle was higher rev was fine.
 
1 - 4 of 4 Posts
Top