Pontiac GTO Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
249 Posts
Discussion Starter #1
What would make the power steering unit (2005 gto) hard to use? Mine is stiff going around slow corners. The reservoir has fluid and there are no leaks that I can see from above and below. A friend said it's the cam I have that is affecting the way the pump is working. One fix is to go with electric but just wanted to hear some opinions. Has anybody experienced this after getting a cam that has a lope to it? Could that really be the reason? Thanks for any input.
 

·
Former Super Moderator
Joined
·
9,919 Posts
Cam should not effect the power steering pump. Sometimes the bushings in the rack get varnished causing the rack to stick, especially in the mornings. I would try some LUCAS power steering conditioner and stop leak. Seen it work wonders with this issue. You'll have to remove some fluid from the pump.
 

·
Registered
Joined
·
249 Posts
Discussion Starter #3
Cam should not effect the power steering pump. Sometimes the bushings in the rack get varnished causing the rack to stick, especially in the mornings. I would try some LUCAS power steering conditioner and stop leak. Seen it work wonders with this issue. You'll have to remove some fluid from the pump.
Thanks, will give that a try.
 

·
Registered
Joined
·
249 Posts
Discussion Starter #4
Cam should not effect the power steering pump. Sometimes the bushings in the rack get varnished causing the rack to stick, especially in the mornings. I would try some LUCAS power steering conditioner and stop leak. Seen it work wonders with this issue. You'll have to remove some fluid from the pump.
Got the Lucas power steering fluid with conditioner, emptied the reservoir and poured the Lucas in and worked very well. Still just a little notchiness at slow speeds but feels way smoother; a huge improvement. I'm hoping it gets better the more I drive it. Thanks for the advice!
 
1 - 4 of 4 Posts
Top