Pontiac GTO Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
My power steering pump whines loudly. Does anyone else have this symtom?
Got the old stethescope out to figure out where the annoyance was exactly coming from. Thanks nick
 

·
Registered
Joined
·
590 Posts
Got rid of my '02 SS Camaro for the GTO. Had a complete new LS1 put in under warranty (piston slap) at 35K and both PS pumps had a little whine to them.
 

·
Registered
Joined
·
33 Posts
My car whines a little too, mostly when I first start it up. I'm not sure if it's the power steering pump...it sounds more like it's in the front of the engine. My dealer said it was normal for that engine. Is that correct?
 

·
Registered
Joined
·
11 Posts
is it a whine, or a churp?, gm p/s pumps are usually quiet unlike the fords, check the level and make sure its full on the dip stick, the only time i see gm pumps whine is when they are low, or have been run when low.
 

·
Registered
Joined
·
160 Posts
I was wondering the same. Mine whines a little on start up
 

·
Registered
Joined
·
6 Posts
Mine is in the shop for that right now. It whined loud (inside the car you can hear the whine as loud as the exhaust) since day one. I gave it a few thousand miles to see if it would 'break in' and go away, but no. So 4600 miles total, it's in the shop for new pump and pulley. I have heard several other GTO's in the St. Louis area, and not a single one was as loud as mine. I would feel embarrased to pull into a place where there were groups of people because this nice, new car has got horrible PS whine...
 

·
Registered
Joined
·
2 Posts
Mine whines a little and took it back to the dealer and they said there is nothig wrong with it. Its olways been the same and now at 9,500 miles it never got worst so it most be normal.
 

·
Registered
Joined
·
1 Posts
Goat666 said:
My power steering pump whines loudly. Does anyone else have this symtom?
Got the old stethescope out to figure out where the annoyance was exactly coming from. Thanks nick
He GOAT666, my 04 had the same problem, I called Pontiac at the number in my owners manual. A tech got on the phone and made an appt with a local dealership who originally said they could not fix it. Well after the tech called em they fixed it in 1 day. Sweet car. Can't wait to complete some mods.

Regards
Tony
 

·
Registered
Joined
·
6 Posts
Well, here is my update on the whine....

They told me on Wed. before Turkey day that they needed to order the pulley for the pump, and it would take 2 days. Fine. I get a call about noon that Monday saying the car was all done.... hmmm that doesn't add up to 2 days, but OK, I go pick it up.

It whined louder than when I took it in. I checked under the hood to make sure they used ATF, not PS fluid, and drove it all week to see if the system needed to be 'cycled'... nope. Taking it back in tomorrow and see what happens then....
 

·
Registered
Joined
·
6 Posts
Got my car back yesterday and they said "It needed bleeding"... which I would guess should have been done during the original pump swap, but things happen. It definitely quieted back down to at least the level before I originally took it in.

I guess the pumps are just naturally noisy.... but then again, I may seek a different dealer for that "second opinion".
 
1 - 11 of 11 Posts
Top