Pontiac GTO Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
customer came in with a procharged gto. 2004 model with the d1sc tuner kit. has the 3.7 pulley with headers, exhaust, decatted, mild cam, bbk intake mani. and 80mm throttle body. all piping and bypass valve checks out. only problem its having is that its only boosting 1.5 to 2 pounds of boost. any ideas? belt tension is good, belts are good, bypass valve is good, about 1mm of shaft play on the actual charger itself. procharger told me its about right to only boost 1.5 to 2 pounds of boost with the current mods but for some odd reason, i dont buy it. i think the charger is dead, any comments or opinions?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
no leaks at all. everything checks out. vacum side is good also. all in the right tolerances. im wondering, i just found an asp performance pulley in the truck. underdrives all accessories by 25 percent. its alot smaller then the stock pulley. i believe this might be the problem. the customer had bought the car from another gentleman. the previous owner stated that the car always made 10lbs of boost. he had taken the car in to get "serviced" before the car was sold to my customer now. looking at this performance pulley, it seems like there is definitley something wrong with it. a piece of the retaining ring on the front side of the pulley seems to be chipped off. im thinking this. change the pulley out for a new asp 948500 a see what it'll do. im also thinking when the previous owner took it in for "service" he actually took it in to get it demodded. there is a superchips programmer manual but no hand held control. i believe he also pulled the aftermarket injectors out and put the stock ones back in. i feel bad for my customer but it seems he has been bamboozled!
 

·
Registered
Joined
·
1,612 Posts
no leaks at all. everything checks out. vacum side is good also. all in the right tolerances. im wondering, i just found an asp performance pulley in the truck. underdrives all accessories by 25 percent. its alot smaller then the stock pulley. i believe this might be the problem. the customer had bought the car from another gentleman. the previous owner stated that the car always made 10lbs of boost. he had taken the car in to get "serviced" before the car was sold to my customer now. looking at this performance pulley, it seems like there is definitley something wrong with it. a piece of the retaining ring on the front side of the pulley seems to be chipped off. im thinking this. change the pulley out for a new asp 948500 a see what it'll do. im also thinking when the previous owner took it in for "service" he actually took it in to get it demodded. there is a superchips programmer manual but no hand held control. i believe he also pulled the aftermarket injectors out and put the stock ones back in. i feel bad for my customer but it seems he has been bamboozled!
That SUCKS...Let us know what the final outcome is... Aren’t the OEM injector’s 30lbs. Maybe lack of fuel is the issue, just a thought…
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
could be lack of fuel but his afr is checking out even though it is only boosting 1.5 to 2 pounds. rofl.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
yea, they are green. just took the intake manifold off and the last shop that put the car together forgot to loctite and tighten all the allen screws underneath the intake manifold. car is a beast. boosting right @ five to six pounds. im guessing about right with the cam he has and mods that are supporting the charger. feels like a charged GOAT! finally. off to the dyno on friday. i will post up the dyno results and also afr. i usually tune supercharged cars right around 11.7 to 12.0 depending on if i pick up knock. ill post results later
 

·
Super Moderator
Joined
·
2,639 Posts
The fuel has nothing to do with the boost being too low. Boost in simple terms is a measurement of resistance. That's why I first thought that maybe there was a major leak in the intake. Maybe there is slippage on the front pulley or the impeller is loose and slipping on the impeller shaft, if that's possible. :eek: I don't have much experience with the Procharger so I'm just reaching for probable causes. Good luck!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
yes you won a prize. check with me for my paypal account address and pay me 5 dollars. lol. jk. also another thing that we just found, previous place that installed the charger did not loctite the tensioner bolts. came right off. also, the main crankshaft pulley bolt was loose. im talking about the pulley for the charger had so much free play in it that when i took the belt off it tilted forward. wtf. some people dont take pride in there work. i hope with this thread it makes other companies step there game up a bit. ill be back to post dyno results and also afr. what do you guys prefer to tune these gto's with? the superchip power programmer that he has or something else?
 

·
Super Moderator
Joined
·
2,639 Posts
yes you won a prize. check with me for my paypal account address and pay me 5 dollars. lol. jk. also another thing that we just found, previous place that installed the charger did not loctite the tensioner bolts. came right off. also, the main crankshaft pulley bolt was loose. im talking about the pulley for the charger had so much free play in it that when i took the belt off it tilted forward. wtf. some people dont take pride in there work. i hope with this thread it makes other companies step there game up a bit. ill be back to post dyno results and also afr. what do you guys prefer to tune these gto's with? the superchip power programmer that he has or something else?
The crankshaft pulley bolt loosening up is a common thing with FI applications. When mine loosened up, the ac belt kept coming off. I spun the bolt all the way out with my bare hand. I was lucky because I had just done about 10 dyno runs (to 140 mph of course) with the pulley being about a 1/4" off the crank. I ordered and installed the crank pinning kit from Magnuson. I think it was around $100.
 
1 - 14 of 14 Posts
Top