Pontiac GTO Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Issue-when my 71 GTO comes off choke at idle it smells very rich & the idle adjust. screws do not seem to do much if anything to help. Once car comes off choke the gas smell out of the exhaust is quite strong, however, I do not see any black smoke. Pulls 10-11 on vacuum in park (best I can remember, need to check again). So far I have adjusted timing & the idle screws, and I drilled a couple holes in the butterflies. None of this had much of an effect.
Last weekend I pulled the top off the carb and verified float is set ok (actually a little low) and noticed that there is no retainer on the power piston??? Also, the power piston dome appears a little beat.
My buddy that is helping me said he has some extra power pistons from Q-jets and most if not all have a prominent tail and retainer. Should I swap out my power piston with one of his, and swap to a lighter spring since my car has a cam & headwork (specs unknown done by PO years ago). Motor is a '71 400 that also has HEI & is otherwise stock. Just seeing if I'm on the right track....
My carb is a 7029268 which I believe is a '69 350/400/428 auto trans 750 cfm.

Other than the rich smelling idle, car seems to run pretty good out on the street...


Thanks!
 

·
Registered
Joined
·
168 Posts
If I recall correctly, drilling one or two small holes in the butterflies helps vacuum signal at idle for bigger camshafts (HP Books QJet book), but for a mostly stock engine it's an attempted bandaid for a bigger problem.
 
1 - 3 of 3 Posts
Top