Pontiac GTO Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
So I did a search, couldn't find much. I do not know much electrically so this is new to me. I took my car to the shop to get the radiator replaced (cracked) and the guy who drove it into the garage was really short. He put my seat all the way forward and then all the way back, it wouldn't go back forward. After that it was smoking and it smelled like an electrical burn. Now my seat won't move, maybe the motor is blown? The switch makes a sound like it is connecting, but nothing happens.
Any idea what I should do; get a new motor and replace it, or would it be easy to just convert it to a manual seat (as I think power seats are dumb and just extra weight)?

Thanks for the help guys.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
Thats what I wanted. But they wanted to charge me saying the problem must have persisted before he operated it... :( gah
 

·
Registered
Joined
·
29 Posts
pull the fuse under the dash and see if it comes back.

if not then take the side seat panel off where you will find a small box with 2 plugs going into it (this is the seat module and is $400 to replace new IF you can find them). My passenger side would do this and click and make some screeching noise. Turns out that the red power wire going into the back of my large white plug could wiggle loose and not make a full connection. I bent it a little so it couldn't move and it's bee OK since.

Pissed me off since sometimes my seat would work and sometimes it wouldn't, then it would screech and smoke, then not work at all. I found a module for cheap out of another set of seats that someone was going to use for office chairs.

It pissed me off that my passenger seat was doing it. I hate when things don't work on my car..bugs the hell out of me. I couldn't imagine it being the driver seat! lol
 
1 - 5 of 5 Posts
Top