Pontiac GTO Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
i just bought my 04 gto, 5.7 auto. stock with muffler delete. my service vehicle soon light (along with an annoying chime) decided to pop on. i have no clue what is setting this off. any ideas?:confused
 

Attachments

·
Former Moderator
Joined
·
2,895 Posts
SVS light can have many different meanings from minor to serious.

I highly recommend a good quality OBD code reader. They are available at most auto parts stores. You can also go to an O'rielly's or other auto parts store and usually they can read and or reset any codes you have.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
This is all i needed thanks! Now to get it fixed!



The Service Vehicle Soon
message along with this
symbol will come on and a
chime will sound if it
detects a problem on the
vehicle.
Such problems could be the Daytime Running
Lamps (DRL) or an automatic headlamp system
malfunction.
If this happens, see your dealer as soon as possible
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Probably oil service. Read the manual for the steps to reset it.
The Service Vehicle Soon
message along with this
symbol will come on and a
chime will sound if it
detects a problem on the
vehicle.
Such problems could be the Daytime Running
Lamps (DRL) or an automatic headlamp system
malfunction.
If this happens, see your dealer as soon as possible


straight from the manual
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
im pretty sure the manual lied. fisrt of all, all of my lghts are fine, and the dlr work great. secondly, today my gurl was driving the car and when she got home, it wouldnt shut off. even with the key out. took it to the shop and they found a bad/melted relay and said another 24hr the car woulda been toasted. not sure if this was the cause of it not starting though. not sure which relay was bad either. anyone ever heard of this happening? think this would be causing my svs light?

f*** shitty dealerships :seeya::shutme
 

·
Registered
Joined
·
2,632 Posts
I'm not understanding.....what did the dealership do wrong?
 

·
Registered
Joined
·
2,632 Posts
Oh, okay. I thought you were talking about the shop that found the bad relay.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
just got the chance to mess with the goat since it messed up with my gurl driving yesterday. turns out the browning relay was the engine control relay. i swapped the relay and it didnt start back up. think it may have a bad ignition switch. when i hooked my battery back up, my check engine light and my battery light were on, another light blinked for a minute or so (think maybe my security light?) then stopped, and my digi speedo was reading 0mph. all with the key in my pocket. when i put the key in, the first click forward feels normal. after that it feels very loose, turnes easily, and dosent spring back at all. it just stays completely forward and i get no feedback at all from my car. the above named cluster lights just stay on the same as if the key was out. any input would be greatly appreciated
 

·
Former Moderator
Joined
·
4,081 Posts
The easiest and most definitive way to see what's making the light come on is to take it to some place like AutoZone or Advance Auto and have them throw their OBDII reader on it. If they aren't sure or you need further clarification make sure to right down every code that comes up.
 

·
Registered
Joined
·
2,632 Posts
I don't think he's able to start it...at least that's what I get from the post.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #14
yeah i cannot start the car. its stuck on the side of the road next to my mechancs shop. im going to try to get a new lock cylinder tomorrow to see if its the problem
 

·
Registered
Joined
·
13 Posts
Discussion Starter #15
car is back on the road. tip of lock cylinder broke off in my ignition switch which left a constant current to my engine control relay. pretty sure the service vehicle soon lght is on due to a headlight out. will find out tomorrow once i install my hids
 

·
Registered
Joined
·
2,632 Posts
Could also be that you fixed the issue (ign switch) and the light just needs to be reset. If is comes back on I would have it scanned by someone with a Tech 2. Many things can be involved with the SES light. ABS, traction control, etc. I'm not really sure a headlight being out would trigger that light.
 

·
Former Moderator
Joined
·
4,081 Posts
A headlight won't. Get it scanned anywhere but write down the actual codes instead of just the parts store's interpretation.
 
1 - 18 of 18 Posts
Top