Pontiac GTO Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
When replacing my 600 edelbrock carb for my 800. I noticed that the inside of my intake manifold was clean on one side but a light brown on the right side (driver side). Any thoughts, thanks as always.

Sent from my PC36100 using AutoGuide App
 

Attachments

·
Registered
Joined
·
3,376 Posts
Or you have a leaky valve allowing exhaust back into the intake. Hope it's just a messed up carb.. Or that's the EGR valve dumping exhaust back into your intake, maybe PCV valve dumping gook. Don't think you have an EGR.. It's not that heavy, so probably not a big deal if the engine has some miles on it.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #4
I think its just a carb issue. Maybe run some seafoam cleaner in the next tank with the new carb. See if that cleans it out

Sent from my PC36100 using AutoGuide App
 

·
Registered
Joined
·
107 Posts
Discussion Starter #5
okay so previous owner/builder just slapped the edelbrock 4brl carb onto of a Qjet manifold. So I installed a 1in square bore - Qjet adaptor block and then the new 800cfm carb. Noticed an instant difference. Just need to adjust the timing for the bigger carb b/c my idle is now off but overall very happy with the new carb. Thanks all
 

·
Registered
Joined
·
668 Posts
I wouldnt worry about it. It looks like a leaky carb or maybe a bit of reversion letting the PCV make things dirty in there. Either way its nothing out of the ordinary, usually I see that on both sides of gas only engines. My RPM is squeaky clean inside, but the intake that was on my HO Formula is full of brown stuff.
 
1 - 6 of 6 Posts
Top