Pontiac GTO Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
249 Posts
Discussion Starter #1
Have had a Spec twin disc clutch in my 2005 for a couple months now and it's got a couple quirks:
When starting up and pressing the clutch pedal I get a whirring noise that stops as soon as I put it in first, then I get a rubbing/squeaky noise as I let out the clutch pedal and a lot of shuddering until the pedal is fully released. Clutch fluid level is good and is a blue color; doesn't look dirty. I think it's slipping as my acceleration isn't as strong as when I first got the car back. Taking it back to tuner who did the work on it but has anybody else had these things happen? Had a new slave and remote bleeder also installed with the clutch but didn't change the master cylinder and have heard different opinions on changing it, some say yes, some say no.
 

·
Former Moderator
Joined
·
4,081 Posts
The sound could be in the trans or bad pilot bearing. It's a good idea to replace the pilot when doing the clutch. A master won't do a thing for your issues. The shuddering is the clutch itself. Had a Spec 3 and let's just say I'm not a fan of Spec anymore.
 

·
Registered
Joined
·
249 Posts
Discussion Starter #3
The sound could be in the trans or bad pilot bearing. It's a good idea to replace the pilot when doing the clutch. A master won't do a thing for your issues. The shuddering is the clutch itself. Had a Spec 3 and let's just say I'm not a fan of Spec anymore.
Thanks, hope I can still be a fan and they (tuners) solve my issues, sure would hate to see $1400 go down the drain.
 

·
Registered
Joined
·
3,765 Posts
Spec is known to chatter
 
1 - 4 of 4 Posts
Top