Pontiac GTO Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hello, been a while since I been here, I have a 66 GTO with the original speedo with a 4 speed, my problem is that, once I hit 30 miles per hr, the speedo will not go above the speed even though I'm going faster than 30 miles per hr, is there a way to test the speedo to see if there's a problem? I'm thinking its something else because it seems to work properly from 0-30 so I'm thinking it wont be the cable.

Thanks
 

·
Registered
Joined
·
117 Posts
Something has to blocking the needle mechanical movement. Have you had the speedo out of the dash and looked at it?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
Something has to blocking the needle mechanical movement. Have you had the speedo out of the dash and looked at it?
Yes, it seem to be ok and nothing causing it to stop. its just weird that it only stops at 30 mph
 

·
Registered
Joined
·
117 Posts
It may need a good cleaning and lubrication of the needle shaft. The spinning thing around the outside of the needle shaft , ( The part that the cable spins)has a little magnet on it, maybe it is weak. I will call it the "Bell"

The bell shaped housing with the magnet is driven by the cable and spins faster with the speed of the car, The magnet pulls the needle shaft further clockwise the faster the bell spins. If the needle shaft has dried out grease it may not move far, also if the magent is weak it wont pull the needle shaft around, . The coil spring holds the needle at zero and provides resistance to keep the needle from registering max speed with minimal movement.It apllies resistance that is overcome by rotational speed of the bell.The faster the bell spins , the farther the needle moves.

Since it seems accurate to around 30 mph where it stops......My money is on dried grease on the needle shaft
 
1 - 11 of 11 Posts
Top