Pontiac GTO Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
249 Posts
Discussion Starter #1
I crank the car put it in first this morning speedo goes right to 200 and then goes to abut 120 until I shift then back to 200 does it up to about 50 then acts right.

Havent taken it in yet
 

·
Registered
Joined
·
249 Posts
Discussion Starter #3
Im waiting on it since I got that warrenty decutable
 

·
Registered
Joined
·
400 Posts
I've had a time or two where my speedo needle went wacko, bouncing all over the place while driving. Came to a stop and it said I was doing 80Mph. I turned the car off, sat for a few seconds then turned the car back on, and everything was ok. I've also had my engine temp warning go off and the needle jumped to the explode side, but then came back down to normal after a second or two. I assumed that was the thermostat sticking...
 

·
Registered
Joined
·
96 Posts
I've had my tach freeze before and my gas gauge go from nearly empty to suddenly showing 1/4 tank before. After filling it up I found that I still had a few gallons in it so it was reading empty with a 1/4 tank of gas in the tank not the other way around. I thought Pontiac had discovered a way to solve our fuel needs, cars that generate there own gasoline.:D
 

·
Registered
Joined
·
432 Posts
I've also had that happen in my 04. They say you can get a computer update that will fix it but I never did. Mine doesn't do it very often. Maybe once ever Six Months.
 

·
Registered
Joined
·
3,541 Posts
They will reflash the cluster and the problem will go away, worse case scenario they replace the cluster.... pretty common problem on the early production 04's.:cheers
 

·
Registered
Joined
·
48 Posts
Justice said:
I've had a time or two where my speedo needle went wacko, bouncing all over the place while driving. Came to a stop and it said I was doing 80Mph. I turned the car off, sat for a few seconds then turned the car back on, and everything was ok. I've also had my engine temp warning go off and the needle jumped to the explode side, but then came back down to normal after a second or two. I assumed that was the thermostat sticking...
Mine did exactly the same and i also turned the car off and turned it back on after a while and everything was ok
 
1 - 8 of 8 Posts
Top