Pontiac GTO Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
Hello
I’m having an issue with my st300 trans.at higher rpm’s it makes a chirping squeaking noice like 2 peace’s of metal rubbing.
This happens in low and drive at around 4000 and higher rpm’s I drop to neutral rev engine no chirp or squeak.
Go back into drive it comes back.

Anybody have any ideas
Thanks for your time
 

·
Registered
Joined
·
4,208 Posts
Hello
I’m having an issue with my st300 trans.at higher rpm’s it makes a chirping squeaking noice like 2 peace’s of metal rubbing.
This happens in low and drive at around 4000 and higher rpm’s I drop to neutral rev engine no chirp or squeak.
Go back into drive it comes back.

Anybody have any ideas
Thanks for your time

That is a question you might have to take to a transmission shop if you think it is a trans problem. Check all the usual things like a broken engine/transmission mount, U-joints, or even a slipping belt on the front of the engine. Check a few other places first as sometimes noises can travel and it can sound like one thing, but be coming from some other part of the car. It sounds like a bearing gone bad to me, but I am not a transmission expert at all, so can't help too much on this one.
 

·
Registered
Joined
·
898 Posts
noise

I had a torque converter grenade on a 68 cutlass that made that sound for about 3 days ..

just on the freeway .. drove side roads to work ... but it blew one morning headed to work..

the weld broke at the snout .... what a fricken mess ..... just left 7-11 630 am with coffee

early 80's ..... no cell phones ... good thing I had a big thumb ....

hope its somethin easy for you ...........

Scott

broken flex plate maybe .... seen that make the chirppee noise too
replaced a few of those on the ole chevy 4x4's I own still mid 80's back to the mid 70 models
 

·
Registered
Joined
·
97 Posts
Discussion Starter #4
Yes it happens at freeway speeds drop too nutreal no sound.no cheap cruising back roads.I put on a new v belt
Still get the chirp.engine has been rebuilt but not transmission.both original numbers matching.I learned back in auto shop class years ago
If you rebuild one the other will soon follow.I replaced motor and trans mount when I dropped the engine in.
I can see it being the flywheel and or the torque converter.I will pull the trans to check so I deceided to go ahead and rebuild the trans
Thanks for yalls input and ideas
It is appropriated

CLP
 
1 - 4 of 4 Posts
Top