Pontiac GTO Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1
I had a 467 pontiac stroker motor i was running in my 67 gto less 100 miles on motor when i got off the freeway my oil pressure droped to less than 5 psi did an oil change let car sit over night started up today still 5 psi or less it goes up to 20 when rpms come up .i don't here rod rap plugs also all wet with fuel and oil were do i srart :mad:...oh ya did a compression test 7 cylinders at about 185 psi one cylinder was 215 any ideas what i should do :confused:confused:confused :shutme:shutme:shutme
 

·
Former Moderator
Joined
·
2,895 Posts
Fuel in the oil? What carb setup? Fuel pump? Pressure?

Sounds like could have washed the rings out with fuel or thinned the oil out so much there was no lubricity left and took out the bearings. Either way, not good. First thing I would have recommended was the compression test and you did that already. What kind of rings are you running? Maybe do a leakdown test also.

I'm afraid you already knew this and sounds like your gonna have to pull her. Hopefully it's just a matter of changing rings/bearings.

Any metal in the oil when you changed it? What oil are you running? Only 100 miles did it have break in oil in it with a zinc additive?
 

·
Registered
Joined
·
137 Posts
Discussion Starter #3
Fuel in the oil? What carb setup? Fuel pump? Pressure?

Sounds like could have washed the rings out with fuel or thinned the oil out so much there was no lubricity left and took out the bearings. Either way, not good. First thing I would have recommended was the compression test and you did that already. What kind of rings are you running? Maybe do a leakdown test also.

I'm afraid you already knew this and sounds like your gonna have to pull her. Hopefully it's just a matter of changing rings/bearings.

Any metal in the oil when you changed it? What oil are you running? Only 100 miles did it have break in oil in it with a zinc additive?
after the cam break in I dumped oil it had zinc in with all the bearing lube the oil that I replaced it was 15-40 with zinc added in also ran a wix filter and a ac delco filter the the rings are seal pro p-molly ...I was hoping to just do bearings and get some good heads not the stupid 670 I am running :(:(:( I should have went with a LS3 conversion :mad:
 

·
Registered
Joined
·
137 Posts
Discussion Starter #5
Aren't a couple of the oil galley plugs a push in style like miniature frost plugs? Maybe one pushed out?
I wish that was all it is ill open the oil pan tonight ...my oil looked like it had 100,000 miles on it ..but has less than 100 miles I think my # 670 heads and timing did me in I need to find a good set of heads and go with a roller cam after I find and repair damage :confused
 

·
64-67 Expert
Joined
·
8,569 Posts
Yep, if it was pinging you very well could have hammered the bearings out, causing loss of oil pressure and further damage. Detonation will destroy an engine.
 

·
Registered
Joined
·
137 Posts
Discussion Starter #7
Yep, if it was pinging you very well could have hammered the bearings out, causing loss of oil pressure and further damage. Detonation will destroy an engine.
well i gave the car a leak down test and i have no more than 5% leak at 90 psi i am going to look in to all new bearings ....also i can get a set of fresh rebuilt #62 heads for $400 this should be better than my 670 i hope also maybe a roller cam and call it a day what do u guys think :confused
 

·
64-67 Expert
Joined
·
8,569 Posts
Your leak down numbers are fine. I don't know about the 62 heads, though. I think they are also around 72-75cc, which means high compression (and race gas needed).
 

·
Registered
Joined
·
137 Posts
Discussion Starter #9
Your leak down numbers are fine. I don't know about the 62 heads, though. I think they are also around 72-75cc, which means high compression (and race gas needed).
i have 30 cc dished pistons i think my compression is 9.5 9.2 -1 looking for a open chamber head i do have 061 but need work
 

·
64-67 Expert
Joined
·
8,569 Posts
061's are a good head. The very first open chamber head by Pontiac, introduced in '67. You may want to use them. You can get more information on them on the 'net.
 

·
Registered
Joined
·
137 Posts
Discussion Starter #11
061's are a good head. The very first open chamber head by Pontiac, introduced in '67. You may want to use them. You can get more information on them on the 'net.
I have 3 sets of heads now 670-061-62 I was going to use the #62 when i repair my stroker motor it has 670 on it now ..I was thinking about selling the #061 heads with the other 400 motor i have because the other block and #061heads have same build date from 1967 :cheers
 
1 - 11 of 11 Posts
Top