Pontiac GTO Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Anybody experience this? I have an 04GTO, and usually run with the traction control off. My wife drove it the other day with the T/C on, and said when she got to 60 mph, the throttle would not allow additional speed and the engine acted like it was being prevented from going faster. I trie dit, and sure enough. It acts like the speed limiter is preventing the car from going over 60. Any suggestions? I have an appoiuntment to take it to the dealer tomorrow.
 

·
Registered
Joined
·
850 Posts
The only suggestion I have is make sure when the dealer drives the car, make sure either you or your wife is present during the drive. This way, if the tech has any questions, either one of you will be there to answer.

This is the first time I've heard of this problem though...let us know what happens.
 

·
Banned
Joined
·
1,196 Posts
ThePrincipal said:
Anybody experience this? I have an 04GTO, and usually run with the traction control off. My wife drove it the other day with the T/C on, and said when she got to 60 mph, the throttle would not allow additional speed and the engine acted like it was being prevented from going faster. I trie dit, and sure enough. It acts like the speed limiter is preventing the car from going over 60. Any suggestions? I have an appoiuntment to take it to the dealer tomorrow.
Grab that lever sticking up between the front seats and pull it straight back. Is that better?:D
 
1 - 4 of 4 Posts
Top