Pontiac GTO Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter #1
I was driving to my friends house and the traction control turned off. Tried pushing the button to turn it on but could not. On the way back everything was fine at the beginning but then I got a CEL and immediately the traction control turned off. Car was running fine on the freeway but in the city when accelerating from a traffic light it was backfiring for a little (kinda like clearing its throat) and then pulling like crazy again and spinning the tires in 3rd. I scanned it when I got home and got a P0101. So how come the MAF is related to the TC? I thought the TC uses just the speed sensors. The engine has heads,cam, fast, NW102, etc. I also put a new MAF when I did the engine work. It wasn't some aftermarket MAF but a stock unit (think it was delphi). I did the engine work 3 years ago and never had a CEL before. I have noticed the TC turning off by itself after the engine work but never cared and never got a CEL.
What can be the issue?
How is the MAF related to the TC?
How is the TC on a GTO supposed to work? Sometimes I am like 45 degrees sideways before it kicks in.
I haven't oiled the filter recently so I don't think I got the MAF dirty.
Thanks for the replies.
 

·
Former Moderator
Joined
·
4,081 Posts
What I've seen is usually the connector on the MAF is corroded or loose and is the problem. You have a LS2 apparently and with the drive by wire the TC is tied in with modulating the throttle. TC on the GTO is pretty basic compared to some newer systems. Basically it is supposed to read the wheel sensors and when a drive wheel is spinning faster than the others after a perdiod of time it kicks in
 

·
Registered
Joined
·
144 Posts
Discussion Starter #3
Thanks for the reply. It is raining and the openings in the banshee hood take the water to the MAF wiring. I dried it, sprayed some electronic cleaner and then cleaned the MAF with MAF cleaner. Car is running fine again. And BTW thats the worst TC system I ever had. I had older cars (97 benz, 2002 benz, 2001 bmw) and there systems were much better. Those cars have less power and have ESP and the GTO has only TC thats not even working good.
 
1 - 4 of 4 Posts
Top