Pontiac GTO Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
It's strange I've been checking this forum for about 3 weeks now since I got my 2004 GTO. I've seen complaints about strut rub, strut leak, bumpers pulling away, bad rear ends, bad paint jobs, leaky door sealants...need I go on? Well...not to sound like an a$$, but I don't have any problems with my GTO. I'm like worried every time I get in it now cuz of all the problems you guys are having. My tires are wearing fine, it's been raining heavy and I've powerwashed the car...no leaks, no strut leaks, the paint looks fine...I mean is there a consensus that these are all GTO problems or are they simply CAR problems? I mean there haven't been too many of these cars made/imported and the way people talk on this forum, hell I guess I'm doomed to have my car sitting in the shop having the front and rear suspensions replaced, the car repainted and while I'm at it maybe tack on a new front bumper! Well...I guess my real question is, HOW SERIOUS are these issues and should I look into getting something like the rear end replaced (I guess I do have chatter in the passenger side rear...but it may be golf clubs LOL) before the warranty expires.

BTW I have nearly 23,000 miles on the car and 4,000 are mine.
 

·
Registered
Joined
·
83 Posts
Like all forums and every car made, all you are going to hear about in majority are those that have problems. This isnt that the car has significant issue but more that 5h!t happens... Things break. Hopefully it never happens to anyone, but when it does thats too bad and needs fixing. A lot about luck but sometimes actual manufacturing problems. Good with the bad I guess...
 

·
Registered
Joined
·
26 Posts
I am with Mickey as an fbody owner and member on those forums as well. Not only does any car have its quirks, but those of us with high power cars tend to well......let's just say the Mazda does not get thrown around like the Camaro.
 

·
Registered
Joined
·
140 Posts
I think the complaints are part of the competitors brainwashing program to make stupid people think the cars are no good. Or from disgrunteld car owners.
 

·
Registered
Joined
·
3,445 Posts
I posted a poll on this issue and the majority of GTO owners had 0 problems with their car.

What you are seeing is open communication on the internet where people can now post all their problems. What you don't see is people posting that theirs is perfect. So people then see problems and the guys with the perfect ones have no reason to find a forum to post on their cars and it looks like the majority are having issues when it's really the minority.
 

·
Registered
Joined
·
1,658 Posts
BostonF4$ said:
It's strange I've been checking this forum for about 3 weeks now since I got my 2004 GTO. I've seen complaints about strut rub, strut leak, bumpers pulling away, bad rear ends, bad paint jobs, leaky door sealants...need I go on? Well...not to sound like an a$$, but I don't have any problems with my GTO. I'm like worried every time I get in it now cuz of all the problems you guys are having. My tires are wearing fine, it's been raining heavy and I've powerwashed the car...no leaks, no strut leaks, the paint looks fine...I mean is there a consensus that these are all GTO problems or are they simply CAR problems? I mean there haven't been too many of these cars made/imported and the way people talk on this forum, hell I guess I'm doomed to have my car sitting in the shop having the front and rear suspensions replaced, the car repainted and while I'm at it maybe tack on a new front bumper! Well...I guess my real question is, HOW SERIOUS are these issues and should I look into getting something like the rear end replaced (I guess I do have chatter in the passenger side rear...but it may be golf clubs LOL) before the warranty expires.

BTW I have nearly 23,000 miles on the car and 4,000 are mine.
Must be an 04 thing. Had mine since Nov 04; has 28k, no major problems:D :D
 

·
Registered
Joined
·
13 Posts
Mine has had a couple of goofy things happen with it.

Like the other day, the high-temp alarm went off. I looked at the gauge, and it was fine. Then about 2 seconds later, I watched it just straight up to H. I turned it off coasting, turned it back on. Has been fine ever since.

Emergency brake got stuck halfway on in January when it was -5 degrees out. E-brake was index wrong from the factory. No problems since.


Low coolant light came on. I poured litterally, 4oz of water into cooling system. No problems since.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #10 ·
Well...I have seen the temp thing first hand. It went all the way up and the alarm went off then went back down almost immediately. No biggy I knew the car was fine....GM has been notorious for having problems w/ their gauges.
 

·
Registered
Joined
·
569 Posts
tlcmetrokc said:
our only problems have been with fit and finish crap, like the kick panel under the passenger side and horn honking by itself. no drive train issues at all
What was the problem with the horn? I was driving down the road once and I swore I heard the horn honk once- my wife and I were looking at each other like we were crazy. I pushed the button to see if it seemed too touchy- like if the heat made it warp until it made contact or something, but it felt fine. Only that once, never happened again.
Joe
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top