Pontiac GTO Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello,

I will appreciate any help you can give me with this.

I have had my 04 GTO for almost a month now and in the past few days the Traction Control indicator on the dashboard says its OFF and it doesn't change if I push the button.

It used turn on and off when pressing the button but now it just stays off.

Can you tell me what could be causing this problem?

Thanks.
 

·
Registered
Joined
·
3,765 Posts
Take it to Auto Zone and see what code is there.
 

·
Registered
Joined
·
257 Posts
Alot of times its something along the line of something ABS. i know when i had my focus it had TC and then the ABS went and my TC OFF came on and stayed on. Dealer **** fixed the ABS and the light went back off.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Thanks for the quick responses.

A funny thing today, the Traction Control button started working again. I turned on the car and saw that there was no T/C off indicator in the dashboard and then tried the button and it turned off and on.

Now I am really worried. I do have a code checker so I will try that later today.
 

·
Registered
Joined
·
3 Posts
my 06 a4 did the same thing. I read the codes and the MAF sensor was bad. i replaced it and the traction control started working fine. IDK if it was just a coincidence or actually connected.
 

·
Banned
Joined
·
23 Posts
I had the same problem with the TC, the MAF code kept going, My sensor was just dirty, cleaned it off and never had the problem again.
 

·
Registered
Joined
·
257 Posts
Can someone explain what the maf has to do with the tc??? im lost lol
 

·
Registered
Joined
·
1 Posts
Awakening an ancient post but I have the same symptoms, TC off without being able to change setting and ABS and brake light on? Any insight would be appreciated
 

·
Registered
Joined
·
2,621 Posts
Awakening an ancient post but I have the same symptoms, TC off without being able to change setting and ABS and brake light on? Any insight would be appreciated
Is there not enough 'insight' in this old thread already?:confused Now, I've never experienced this but it does seem like they did give you a couple of things to look into.
 

·
Registered
Joined
·
159 Posts
\I would check all your connections under the hood, when i installed a new heat soak sensor into my intake it caused the t/c to stay off permanently. I rechecked the connection and determined it was not clipped in all the way, i fixed this and the traction control came back on.
 

·
Registered
Joined
·
2 Posts
tc stays off

I replaced the light bulbs with LED and ever sense the TC stays off , went back to regular light bulbs and the problem went away
Just something to check .
 

·
Registered
Joined
·
2 Posts
hello, I replaced the brake lights with LED light bulbs and the TC stays off tried to push the TC on/off switch to turn it on didn't
work went back to original light bulb , problem went away, Just something to look at , I am sure that was mentioned on the forum before.
 

·
Registered
Joined
·
2,621 Posts
5 year old thread........6 if you go back to the original poster.
 
1 - 15 of 15 Posts
Top