Pontiac GTO Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter #1
Silly question, My trunk light does not come on am I missing something I have looked for a switch found nothing. I guess the bulb is burnt out but I am thinking already.... Any Ideas ?
 

·
Registered
Joined
·
746 Posts
It's on the trunk. When you lift the trunk up, it's kinda in the middle of the trunk. It's a little white or tan peg about a inch long. Kind of hard to put it in writing.
 

·
Registered
Joined
·
316 Posts
I had a similar problem with mine, I pulled the light cover off and found that the bulb was not all the way in the sockets. if you have a similar problem, be carefull puting it back in its a little tight and you may ground it out and blow a fuse, but should be a quick fix.
 

·
Registered
Joined
·
2,473 Posts
gameover said:
Mine has a mind of it's own, sometimes it comes on, sometimes it doesn't.
Haven't had a chance to check it out.
:cheers

Lol. I was gonna post the same thing.

I'll check the peg-- thx.
 

·
Registered
Joined
·
231 Posts
Discussion Starter #10
Ok checked the peg and its screwed up you have to jiggle it and then the light comes on. I figured after a couple jiggles it should work but after closing the trunk same thing seems to be a faulty switch. This sucks if I have to take it in just for this I got a $30k car with 400 horses under the hood barely 200 miles but no trunk light. :lol:
 

·
Registered
Joined
·
4 Posts
The trunk light switch had to be replaced on my 05. So far the only problem with the car.

I have only recently joined this list. It has been interesting reading about experiences of fellow GTO owners. I've had mine since June of last year.
 

·
Registered
Joined
·
316 Posts
speaking of that end of the car, has anyone had any problems with the paint on their spoiler. Only part put on in the US and I have what look like water spots on the paint under the clear coat. Dont have them anywhere else on the car
 

·
Registered
Joined
·
233 Posts
Braman...the paint issue has been discussed several times on the forum. Try entering "Paint Question" or "Paint problems" in the forum search and you will find those threads. Basically, it is an issue with moisture under the paint. A heat gun appears to be the generally accepted answer.
 

·
Registered
Joined
·
1,083 Posts
I found that my switch was not "pulling out" far enough. Like there's an obstruction inside the sleeve the post comes out of. When I just pull on the post, I can feel it pop past the obstruction and the light comes on.

I've got a short list; rattle in door, now trunk light I'm making up to go to the dealer. I just can't bring myself to let them tear parts of it down yet, so unless it's something major, I'm waiting till it gets nearly a year old.
 

·
Registered
Joined
·
304 Posts
lotaguts said:
Ok checked the peg and its screwed up you have to jiggle it and then the light comes on. I figured after a couple jiggles it should work but after closing the trunk same thing seems to be a faulty switch. This sucks if I have to take it in just for this I got a $30k car with 400 horses under the hood barely 200 miles but no trunk light. :lol:
That's what your dealer is for.........

JET
 
1 - 15 of 15 Posts
Top