Pontiac GTO Forum banner

1 - 9 of 9 Posts

·
RIP (12/27/60-7/18/15)
Joined
·
767 Posts
Discussion Starter #1
My turn signals dont work.
I have replaced the relay but that didnt work.
the lights come on, both on the dash and the read tail lighs, but they wont blink.
My hazard ligts work fine
what could it be?
thanks as always
 

·
Premium Member
Joined
·
4,703 Posts
How about the front turn signal? Did you check BOTH flashers ? One on the fuse panel, and 1 under the dash just to the left of the steering column......Uncle E:cheers
 

·
RIP (12/27/60-7/18/15)
Joined
·
767 Posts
Discussion Starter #3
Yes Uncle E, I did.
the front lights i dont have hooked up yrt.
I suspect the turn signal flasher is designed to work with ALL the lights hooked up,to
have the correct load, thus proper current draw........
at least it sounds good in theory
take care
:cheers
2 more hours to Beer time!!!!
:party::party::party::party:
 

·
64-67 Expert
Joined
·
8,569 Posts
Topkat, move down here to California. You won't need the turn signals ever (no one uses turn signals here except a few old fossils driving old cars like myself)....and they sell Longhammer IPA at the local Save Mart. No turn signals, cold beer, and a muscle car.....it's as good as it gets!!
 

·
RIP (12/27/60-7/18/15)
Joined
·
767 Posts
Discussion Starter #8
I came from CA geetee, it took me 47 years to get out of there lol.
there's mo smog checks here, registration is a flat rate................and there's no state income tax.:D
thanks anyway :cheers
:party::party::party::party::party::party:
 
1 - 9 of 9 Posts
Top