Pontiac GTO Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1 (Edited)
2006 M6. K&N intake and SLP LMII axelback.

Issue is, when you first fire the car up, it idles very rough and sometimes stalls. If you use anything that draws significant power, you can hear the engine bog down and almost stall. Windows, blower fan. Radio doesn't seem to affect it. Once you start driving, it doesn't seem to have full power, and runs rough. Have to feather the gas while stopped or it stalls. It is at the dealer right now, as it is still under warranty. They replaced an O2 sensor and the Mass airflow sensor. Hasn't fixed a damn thing. Anyone experience this issue? Any ideas?
 

·
Registered
Joined
·
91 Posts
no but it sounds alt related I wonder if it's out putting but really low. Probably not the problem but a theory being this motor is 10.9.1 compressin if the bat was low enough to cause it to barly run it wouldn't start.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #3
It is at the dealer right now. They replaced the mass airflow sensor and the O2 sensors. It didn't fix it at all. I don't think the mechanic believed me that the window switches caused the engine to stall, until he went to back it out of the garage bay and put the window down, quit on him right there... Well, he fired it up, pulled it back in and the service manager called Enterprise for a rental. Told me should be ready tomorrow, even though they don't know what it is. Who the hell knows, mechanic said something about the alternator. Let you know when I know I guess. Really sucks, bought the damn thing Saturday and picked it up yesterday and it's already in the shop.:mad::mad:

P.S. Now driving around in a brand new black Suburban that had 6 miles on it when I pulled out of the lot. That's right, six. Enterprise took delivery of it at that dealer, and it hadn't even gone to their lot yet. Pretty cool truck.:cool
 

·
Registered
Joined
·
68 Posts
Discussion Starter #5
Got a voicemail from the service dept. today. They say they think it is a easy fix, needs "throttle body servicing". Not sure what they mean, as long as it runs OK when they're done, I don't care. The car has been in the shop more than with me since I bought it.
 

·
Registered
Joined
·
197 Posts
im surprised they didnt void your warranty with those mods. check the connection to the mass, connections to tb. if you have a tune. they might have to bump up the idle a bit.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #8
Car is as it was when I bought it from them and purchased the extended warranty, so I believe they need to warranty it as it is. It is not tuned to my knowledge. I had the car home for one day since I bought it. Very frustrating.
 

·
Registered
Joined
·
19 Posts
Possible that the IAC could be bad? Does the car react when the A/C is turned on? - meaning do the RPMs fall, or stay steady, or drop? Could also be a Short...
 

·
Registered
Joined
·
68 Posts
Discussion Starter #10
Well, they say it was the CAI or something. I don't see how that would affect the electrical system. They ordered an OEM intake and are putting it on, claim it should fix the whole thing. I still just can't comprehend how that can cause the window motors to shut the engine off.:confused
 

·
Registered
Joined
·
91 Posts
Well, they say it was the CAI or something. I don't see how that would affect the electrical system. They ordered an OEM intake and are putting it on, claim it should fix the whole thing. I still just can't comprehend how that can cause the window motors to shut the engine off.:confused
It can't but most dealer mecahnics are idiots. That's why they end up at the dealer. I wonder if they even pulled a wave form on the spark at all.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #12
Well, I picked it up today, and all seems fine. Runs strong, idles smooth. They claim all they did was replace the K&N with a stock air box and filter. Still baffled as to how that could have been the cause, but it seems to have worked, so good riddance I guess.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #14
I guess that is a possibility. I was planning on replacing the K&N anyway, it looked like they previous owner really cobbed it up when he put it on. Let's just say duct tape was involved... If I decide in the future I want another one, I think I would go with a OTR style setup.
 
1 - 14 of 14 Posts
Top