Pontiac GTO Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
156 Posts
Discussion Starter #1
Went to the track last night (Richmond Dragway), along with some other GTO's. There was one 05 A4 with 160 thermostat, DR's and cai going 13.2 Another GTO, Torrid Red A4 with mods, wheels, and some other stuff from Oklahoma. Both were really cool guys.

Myself I couldn't muster better than a [email protected] The Density Altitude was near 2900-3000 all night and I can't get this thing to hook when changing gears to save my life. I feathered the launch around 2900-3000rpms and seemed to work well with a few 2.1 and a couple 2.2 60's.

These cars really need a tire. My coolant temp was around 215-222 all night. No matter how long I let it sit it wasn't long enough for proper cool down. Also heard you can undo battery and regain some of the timing, but forgot my socket set at home.

I ran the car with the spare/jack in it, 93 octane with a 1/4 tank, and myself driving.

I did correct the times and they seem to put me around 335rwhp, 395 crank hp, and the times come to be 13.4's at 105-106ish. I really feel the DA was killing it.

How do you guys hardwire ground your fans so they stay on all of the time when the car is off. I'm really interested in doing that to my car. Also could I remove my MAF screen, would I run too lean? What would it do?
 

·
Registered
Joined
·
3,445 Posts
Don't remove the MAF screen. For the small gain 2-4 hp that you get you take the chance of trashing your engine.

As far as the temp's, did you remove your fuel rail covers and the hood plugs? Also how long were you letting it cool down? I've found a half hour minimum and close to an hour to get it to be below 190 at launch time. Also depends on how busy the staging lane is.

All in all, getting into the 13's with the air you had wasn't bad. Try a lower RPM launch next time. I'm hitting between 2000-2500 depending on how sticky the track is and getting low 2.0 60' times.
 

·
Registered
Joined
·
156 Posts
Discussion Starter #3 (Edited)
Yeah the denisity altitude was holding me back a bit, it between 85-95 degrees with about 80% humidity. Not to mention being a street legal car night, they don't prep the track at all. I have done 2000-2400 before and was getting high 2.2's. With the 2900 launches I was got a best of 2.14. I feel as though the heat was holding me back. I was down to 177deg when I went to run last run. But, my lane was moving and I had to start it up, by the time I got to the line I believe I was at 212.

A lot of my friends told me to remove the MAF screen. But even when I had my Mustang, I thought the chance of it running a little lean without being on a dyno I decided against it.

VA is a pain to get a DA of less than 2500, maybe the last track night in November I can pull something out.

I will try 2500 next time though. I leave the hood baffles removed all of the time. But left the GTO covers on.
 
1 - 3 of 3 Posts
Top