Pontiac GTO Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
380 Posts
Discussion Starter #1
Hello all,

By any chance does anyone have or know how to get a windshield washer blueprint or skymatic? Reason why I am asking is because I've been having an issue with it for over a week. My washer fluid has not been spraying even though I can hear the motor making noise. I was messing with it a few minutes ago by tapping the hoses to make sure they weren't caught in anything and then the fluid just leaked from underneath the passenger seat. Is that where the tank is or the does the line pass through there? Thought that was kind of strange but if anybody has had that same problem or has a remedy or suggestion on how to fix, it would be appreciated. Thanks.
 

·
Super Moderator
Joined
·
8,430 Posts
You may want to check with your Pontiac Parts Dept. They should have a schematic for you to look at. They could even print it out for you. The tank is located up near the radiator.

Leaking from under the passenger seat?? Could be the fluid is running down the firewall under the carpet and surfacing at the split in the seams under the seat. You may have a clog somewhere. Have you examined the holes in the spray ports on the hood? Are they waxed shut? Obstruction in there? Try taking a small pointy object and put it in the holes and wiggle to see. Disconnect the hose from under the hood and try taking an air hose and blow air in the holes to make sure they are open. If they are, remove the hoses from the pump and blow air through them. If still clogged your next step is the pump itself. Could be some dirt is lodged in a port preventing the spray. If all else fails look at replacing the pump.
 

·
Premium Member
Joined
·
4,162 Posts
Your windshield washer tank and motor is located in front of the inner RF wheel well. Follow the hose up along the passenger side finder behind the underhood fuse/relay box up to the hood.
 

·
Registered
Joined
·
380 Posts
Discussion Starter #4
Thanks you guys. Luckily the fluid is not leaking into the car rather running underneath from the reservoir. I'm going to try to go to a local Pontiac dealer so I can get a schematic on how to check it out. I'm going to try your suggestions of checking the hoses any way before I start messing with the tank or the motor since it still sounds as if its working. Thanks gm4life cause thats where the fluid is leaking from. Thanks you guys for the info.
 
1 - 5 of 5 Posts
Top